What are the browser and device requirements?

Written by Paul Vecchiato

Last published at: August 5th, 2021

Player, Sites and Console

Browser Version Notes
Microsoft Edge 40+ Using the latest version is highly recommended
Firefox Latest Firefox automatically updates itself to the latest version, although prior versions should work, only the latest is tested.
Chrome Latest Chrome automatically updates itself to the latest version, although prior version should work, only the latest is tested.
Safari  6.0+  
Safari iOS  6.1+ Console is not supported for mobile devices
Android mobile 2 4.3+ Console is not supported for mobile devices
Viostream will serve an HTML5 player.
Users who access Viostream using an unsupported browser will be notified via a banner at the top of the page.

Browser support policy

Viostream policy is to deprecate support for browsers when they fall below 5% market share in our customers’ home markets. We encourage customers and end-users to upgrade to the most recent browser version. As an example, IE11 is no longer supported as it has less than 5% market share in Australia, Singapore, Malaysia, Indonesia and the United States 1.

Additionally, browsers that have reached end-of-life from their suppliers are unsupported from the moment their provider ceases to provide support (e.g. IE6-10). We will not actively stop our services from working on these browsers, however we cannot guarantee our service to work. Viostream strongly suggests our customers upgrade their browsers as unsupported browsers will no longer receive any security or efficiency upgrades form the vendor.

1 Viostream uses http://gs.statcounter.com/ as a reference to determine these percentages.

2 Only tablets that have more than 5% market share are supported, e.g. Samsung, Google, ASUS. Viostream only supports Android using their native browser and native player that can accept HLS content.